If you published a new store and go to https://localhost/webapp/wcs/stores/servlet/en/newstore, you just might end up with the Firefox error:
SSL_ERROR_NO_CYPHER_OVERLAP

To get around that error, type about:config into the Firefox address bar.

Using the search box, enter in security.tls_.version.max

Double click on the preference name and change the value to 1

After that, you should be all set to refresh the localhost page, and the error will be gone and your new store will load.

security.tls.version.max